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EPG behavior applying CU:- Users unable to see CAPTCHA and no successful tarpit.

This article applies to the following products:

  • Messageware EPG 2019
  • Messageware EPG 2016
  • Messageware EPG 2013

 


SYMPTOM

The behavior occurs after performing an Exchange Server Cumulative Update with the EPG Exchange component still in place. Users will experience the following:

  • Password failures are not recorded
  • Users do not enter tarpit after repeated failures
  • Users cannot see captcha and recent activity page

 


CAUSE

When the Exchange Server Cumulative Update is applied, the cumulative update overwrites and replaces different Exchange Protocol web.config files found in C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy 

 

Example of a typical EPG module entry found on a web.config file.

 

  • This error message can be found in Event viewer after the update has been applied 
    • Event Viewer > Windows Logs > Application 
  • The error will be generated from Messageware Service ID1001.

Error Message:

EPG Monitor detected missing modules.  Recommended action is to reinstall EPG CAS component.
Deployment Integrity Feature Details:

    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\sync\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\mapi\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\owa\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\EWS\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\Autodiscover\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\Rest\web.config
    Check file : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\OAB\web.config

 

 

No captcha at OWA Login :

 


SOLUTION

To resolve this behavior follow the solution:

  • Re-install the EPG Exchange component on each Exchange Server. This component is named according to the major version of Exchange:
  • Messageware_EPG_2019_v 
  • Messageware_EPG_2016_v 
  • Messageware_EPG_2013_v

 

Re-install the EPG Exchange component by following the steps:

  • Stop and disable the World Wide Web Publishing Service (W3SVC)
  • Navigate to where EPG installation files are located.
  • Right-click on the EPG exchange component and run with elevated permissions
  •  
  • Once the installation is completed, restart the World Wide Web Publishing Service (W3SVC)

 

Re-installing the EPG CAS component on each Exchanger Server will add the modules back in the web.config file and after the services are restarted EPG functionality will return to normal. To verify EPG functionality:

  • Clear browser cache and launch OWA
  • On login, captcha will be visible now