Home > Knowledge Base Articles > Missing UPN, users getting GetADProperty Failed to get UserPrincipalName error in event viewer

Missing UPN, users getting GetADProperty Failed to get UserPrincipalName error in event viewer

This article applies to the following products:

  • Messageware EPG 2019
  • Messageware EPG 2016
  • Messageware EPG 2013

 


SYMPTOM

In event viewer users are getting GetADProperty Failed to get UserPrincipalName error


CAUSE

The userPrincipalName is not set in Active Directory (AD) due to which this error is persisting.    


SOLUTION

Assign the userPrincipalName in Active Directory

  • Open Active Directory
  • Right click on the user account that has the issue and click properties
  • Click Attribute Editor and navigate to userPrincipalName in the list
  • Set the userPrincipalName to a value of your specification 
  • Click Apply and OK