Home > Knowledge Base Articles > EPG Alerts are not sent to the “Alert email recipient” when both EPG CAS component and EPG Monitor are installed on the same Exchange server

EPG Alerts are not sent to the “Alert email recipient” when both EPG CAS component and EPG Monitor are installed on the same Exchange server

This article applies to the following products:

  • Messageware EPG 2019
  • Messageware EPG 2016
  • Messageware EPG 2013

 


SYMPTOM

Alerts are not sent when both Messageware EPG CAS component and Messageware EPG Monitor are installed on the same Exchange Server.

The following errors are written to the event log:

Event ID 0:

Description: OG_Alert, Run: Failed sending email

Event ID 0:

OG_Alert, SendMail MWExeption: FunctionName: SendEmail


CAUSE

This occurs when both Messageware EPG CAS component and Messageware EPG Monitor are installed on the same Exchange Server and the Exchange Web Services URL is misconfigured in EPG Alerts.


RESOLUTION

 To resolve this behavior make sure that the EWS URL is pointing to the server where Messageware EPG CAS component is installed following the instructions below.

  1. Launch the Messageware EPG Administration console
  2. Open the Alerts page and navigate to Exchange Web Services (EWS) URL
  3. Click the Edit Button and make sure that the URL is pointing to the server where the Messageware EPG CAS component is installed, by using the FQDN or the local server name

In the picture below we are using FQDN (Server1.contoso.com) to point to the server where EPG Messageware CAS component is installed 

Figure 1- EPG Messageware CAS component is installed on 'server1.contoso.com'

  • Click Update and the Save button to save your changed 
  • Wait two minutes for the changes to take effect 

(Note: Alternatively, the World Wide Web Publishing Service can be restarted for the changes to occur immediately.)