Users are unable to see Messageware Plus Pack features in OWA

This article applies to the following products:
     Messageware Plus Pack 2003

     Messageware Plus Pack 2000

 

SYMPTOM

 

When logging into Outlook Web Access, the Plus Pack functionality is not present.

 

CAUSE

 

There are several causes for this issue; some of the possible causes are outlined below.

 

·          Plus Pack license key is invalid

·          Messageware ISAPI filter is not loaded

·          WinHTTP proxy configuration is blocking local requests

·          Mismatch in Windows IIS Authentication settings

·          Older version of the Plus Pack is installed

 

TROUBLESHOOTING STEPS

 

The action items will step through the causes listed above in detail.

 

Plus Pack license key is invalid

To ensure that the Plus Pack license key is valid, follow the steps below

 

1.     Using Internet Explorer, enter the following  command:
http://<ExchangeServerName>/exchweb/bin/mw_lwqe.dll?cmd=show&debug=yes

2.       If the license is OK the response is “200 OK”

 

Messageware ISAPI filter is not loaded

The Messageware ISAPI filter must be loaded for Plus Pack functionality to be present. Below are the steps to verify.

 

1.     On the server, open the IIS Manager and navigate to \Web Sites\<OWA website>

2.     Select Properties on the OWA website

3.     Move to the ISAPI Filters tab

4.     If there is no Messageware Web Service ISAPI filter, add the filter

a.     In the ISAPI Filters tab click on the Add button

b.    For Filter Name, enter "Messageware Web Service", without quotes

c.     For Executable, click on the Browse button and navigate to \Program Files\Messageware Core Services\Filter\MW_Core.dll

d.     Restart the World Wide Web Publishing Service

5.     If there is a red arrow next to the filter, contact Messageware Support

 

NOTE: The filter should be added to all OWA websites for which the Plus Pack functionality should be present

 

Configuring WinHTTP proxy

WinHTTP proxy configuration forwards local requests to a proxy server. This will prevent a client from seeing either Plus Pack or AttachView functionality. This issue will only occur on a front-end server and can be corrected by adding the front-end server where the Plus Pack is installed, to the WINHTTP bypass list using the proxycfg command.

Follow the steps outlined in the following Messageware knowledgebase article to correct this issue:

Error “File Retrieval error. (31 – 0x2ee7)” appears when viewing attachments in AttachView and Symantec Enterprise Vault is present
http://m3.messageware.com/kb/customer/KBArticle.aspx?articleid=72


Mismatch in Windows authentication settings

Follow the link below to be directed to the Messageware knowledgebase article on configuring Windows authentication settings.

How to verify the IIS Authentication Settings

http://m3.messageware.com/kb/customer/KBArticle.aspx?articleid=101

 

Upgrading to the latest version of the Plus Pack

Follow the link below to be directed to the Messageware knowledgebase article on upgrading Messageware products

Upgrading to the latest version of Messageware products
http://m3.messageware.com/kb/customer/KBArticle.aspx?articleid=100

 

 

This article applies to the following products:
     Messageware Plus Pack 2003

     Messageware Plus Pack 2000