Users receive "Error Code 500 Internal Server Error. Contact your ISA Administrator (12217)" when viewing an attachment

This article applies to the following products:
     Messageware AttachView 2003 v8.1 and earlier

     Messageware AttachView 2000 v8.1 and earlier

 

SYMPTOM

 

Users connecting to Outlook Web Access via ISA 2004 receive the following error when viewing attachments:

 

“The page cannot be displayed”

Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact your ISA server administrator. (12217)

 

CAUSE

 

This error occurs in environments where the ISA HTTP filter has the “Verify Normalization” option enabled. The feature blocks legitimate requests that contain a ‘%’ symbol which represents a space in the URL.

 

RESOLUTION

 

To correct this issue, follow the steps below to disable normalization on the ISA 2004 Server.

 

1.     Open the ISA Server Management Console (Start\All Programs\Microsoft ISA Server\ISA Server Management)

2.     In the ISA Management Console, navigate to the Publishing Rule (Microsoft Internet Security and Acceleration Server 2004\Arrays\<Array Name>\Firewall Policy (ISA2004)

3.     Right click on the OWA Web Publishing rule and select "Configure HTTP"

4.     On the "General" tab, uncheck the "Verify normalization" and "Block high bit characters" options

5.     Apply the changes

6.     Clear your local browser cache (Tools\Internet Options\Delete Files)

7.     Login to OWA and verify that the issue has been corrected

 

MORE INFORMATION

 

This interoperation issue has been corrected in AttachView 8.5 that can be downloaded from our Customer website.

 

REFERENCES

 

HTTP Filtering in ISA Server 2004
http://www.microsoft.com/technet/isa/2004/plan/httpfiltering.mspx

 

 

This article applies to the following products:
     Messageware AttachView 2003
v8.1 and earlier

     Messageware AttachView 2000 v8.1 and earlier