Users receiving “This page has expired” message when viewing attachments in OWA using AttachView 2007/2010

This article applies to the following products:
     Messageware
AttachView 2010
     Messageware AttachView 2007

SUMMARY


When viewing attachments in OWA users receive the following message:

“This page has expired”    

CAUSE


This behavior typically occurs when the server is running in a load-balanced configuration with persistence disabled.
 

RESOLUTION

When a user views an attachment the attachment is converted into html files that are temporarily cached on the Exchange Server. The persistence option must be enabled on the network load balancer to ensure all AttachView requests are consistently directed to the server where the converted files are located.


This article applies to the following products:
     Messageware AttachView 2010
     Messageware AttachView 2007