Conversions of DLL files in OWA result in large files being written to the AttachView Temp folder on the Client Access Server

This article applies to the following products:
     Messageware AttachView v1.9a 2007

 

SYMPTOM

 

When converting a particular DLL attachments in OWA, the corresponding conversion in the AttachView TEMP folder on the Client Access Server is become very large in size

 

 

CAUSE


This behaviour is related to a problem with the AttachView engine (PEEngine.dll) responsible for conversions of DLL files.
 

RESOLUTION

 

To correct this issue, follow the steps below which involve applying an updated PEEngine.dll file.

 

1.      On the CAS, download and extract the following file to a temporary location http://w3.messageware.com/download/support/KB/698_UpdatedPEEngine.zip

2.      Proceed with installing the Visual C++ 2005 SP1 redistributable package from the download link below.  The file that is required to be installed is vcredist_x64.exe

3.      Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26347

4.      Navigate to the following location \Program Files\Messageware\AttachView\COM\

a.      Rename the existing PEEngine.dll to PEEngine.old

b.     Paste the updated PEEngine.dll

c.      Verify the NTFS permissions match

5.      Open up a command prompt window to register the DLL (Start\Run\cmd)

a.      Navigate to \Program Files\Messageware\AttachView\COM\

b.     Type in the following regsvr32 PEEngine.dll

c.      Click Ok and exit the command prompt window

6.      Open up Component Services (Start\Administrative Tools\Component Services\)

a.      Navigate to Component Services > Computers > My Computer > COM+ Applications

b.     Right-Click on AttachView PE Engine and choose Disable

c.      Right-Click on the AttachView PE Engine and choose Enable

 

This article applies to the following products:
     Messageware AttachView v1.9a 2007