Users receive an error when attempting to convert PDF attachments

This article applies to the following products:
     Messageware AttachView 2007 v1.9 and v1.9a 

 

 

SYMPTOM

 

When a user attempts to convert PDF file attachments they may the following error message below:

 

Error: -2147467259 Unspecified error (-2147467259 - 0x80004005)

 

CAUSE

 

This may occur if the PDF was generated using a third party utility.

 

RESOLUTION

 

To correct this behavior, apply the updated PDF engine.

 

1.     On the CAS, download and extract the following file to a temporary location

       http://w3.messageware.com/download/support/Kb/595_AttachView_1_9_UpdatedPDFEngine.zip

2.     Navigate to \Program Files\Messageware\AttachView\Pdf\

a.     Rename the existing bin directory to bin.OLD

b.    Paste the updated bin directory

c.     Verify the NTFS permissions match with the existing directory

3.     Open up a command prompt (Start\Run\cmd)

a.     Navigate to \Program Files\Messageware\AttachView\Pdf\bin\

b.    Type the following command: regsvr32 Pdf2ImgOCX.dll

4.     Restart the World Wide Web Publishing Service for changes to take immediate effect

 

MORE INFORMATION

 

This will be included in the next release of AttachView 2007.

 

This article applies to the following products: 
     Messageware AttachView 2007 v1.9 and v1.9a