In a CAS to CAS proxy environment users are unable to convert, open or save attachments using AttachView

This article applies to the following products:
     Messageware AttachView 2007
 

 

SYMPTOM

 

When opening emails containing attachments, the following symptoms are present:

 

1.     Two binocular icons appear next to each other

2.     When converting attachments using the AttachView binoculars, an  HTTP 404 error occurs and the following message is displayed: “Internet Explorer cannot display the webpage”

3.     When clicking on the attachment, a script error may occur and a second instance of the email message is opened

 

CAUSE

 

This behavior occurs when the two CAS servers are located in two separate Active Directory Sites and the requests are being proxied from one CAS to another

 

RESOLUTION

 

To correct this behavior apply the steps below on all the Client Access Servers that have Messageware products installed on them.

 

Note: Restarting the World Wide Web Publishing Service is required

Note: The following needs to be applied on all CAS servers where Messageware is installed

Note: Verify the NTFS permissions match with the existing files

 

 

1.     Download the fix using the link below

                http://w3.messageware.com/download/support/KB/541_AV18a_CAStoCAS_UpdatedCoreServices.zip

2.     On the CAS, navigate to \Program Files\Messageware\Common files

3.     Rename CoreServices.dll to CoreServices.old

4.     Copy the updated CoreServices.dll to this location

5.     Restart the World Wide Web Publishing Services for changes to take effect

 

MORE INFORMATION

 

This above correction will be included in the next version of AttachView

 

This article applies to the following products:
     Messageware AttachView 2007