Users receive multiple Red X images when trying to print a calendar

This article applies to the following products:
     Messageware OWA Print 2007

   

 

SYMPTOM

 

When printing calendars the hardcopy shows several Red X images instead of the calendar content

   

CAUSE

 

This issue occurs if the registry.xml file is not correctly updated after the Exchange Server has been upgraded with Exchange 2007 Service Pack 2


RESOLUTION

 

To correct this issue, follow the steps below. If user is unable to find the string in the registry.xml file, reinstall OWA Print and Plus Pack. Plus Pack need to be reinstalled because it shares the same file pages with OWA Print.

 

1.      Edit the registry.xml in the premium and basic folder (\Program Files\Microsoft\Exchange Server\Client Access\Owa\forms\)

2.      On the registry file, search for string ”MwCalendarPrintGridForm.aspx” including the quotations.

3.      Highlight the entire line starting with <Mapping xmlns and ending with RequiredFeatures=”Calendar”/>.       

4.      Replace it with <Mapping xmlns="" Action="MwPrint" Form="MwCalendarPrintWebForm.aspx" RequiredFeatures="Calendar"/><Mapping xmlns="" Action="MwPrintGrid" Form="MwCalendarPrintGridForm.aspx" RequiredFeatures="Calendar"/>

5.      Save any changes made in the file.

 

   

This article applies to the following products:
     Messageware OWA Print 2007