An HTTP 404 error is returned when clicking on a hyperlink contained in the body of an email message

This article applies to the following products:
     Messageware AttachView 2003

 

SYMPTOM

 

An HTTP 404 error is returned when clicking on a hyperlink contained in the body of an email message.

 

This issue pertains to proxying from a CAS 2007 server to an Exchange 2003 Backend server where AttachView is installed.

 

CAUSE

 

This issue occurs due to a missing Application extension for the Exchweb\bin virtual directory in IIS

 

RESOLUTION

 

To correct this issue apply the steps below on all Exchange 2003 Backend servers where AttachView is installed

 

1.     Start a command prompt and navigate to <Drive>\inetpub\adminscripts

2.     Run the following command, all on one line without pressing ENTER, paying careful attention to the quotes and spacing.

IMPORTANT NOTE
: Remember to verify the drive letter for the path.


cscript c:\inetpub\adminscripts\adsutil.vbs set w3svc/1/root/exchweb/bin/ScriptMaps ".srf,C:\Program Files\Messageware Incorporated\AttachView for Outlook Web Access\VDir\Bin\attachviewisapi.dll,0,GET,POST" ".asp,C:\Windows\system32\inetsrv\asp.dll,5,GET,HEAD,POST,TRACE"

If successful, the result will show:

 

Microsoft (R) Windows Script Host Version 5.6

Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

 

ScriptMaps                      : (LIST) ".srf,C:\Program Files\Messageware Inco

rporated\AttachView for Outlook Web Access\VDir\Bin\attachviewisapi.dll,0,GET,PO

ST" ".asp,C:\Windows\system32\inetsrv\asp.dll,5,GET,HEAD,POST,TRACE"

 

 

This article applies to the following products:  
     Messageware AttachView 2003

 

Add Feedback