Users are unable to view attachments when navigating between messages using the navigation arrows

This article applies to the following products:
     Messageware AttachView 2007

 

SYMPTOM

 

When navigating between messages in OWA Light using the navigation arrows, users are unable to view attachments and receive the following error:

 

Messageware Attachview

For Microsoft Office Outlook Web Access

 

file retrieval error.(31 - 0x80040060)

 

CAUSE

 

This issue occurs as a result of the Message ID changing from the original when navigating to a new email using the arrow buttons in OWA light.

 

AttachView is unable to use the altered ID to retrieve the attachment; therefore users receive the error message.

 

RESOLUTION

 

To correct this issue follow the steps below on obtaining an updated DLL to apply on the Client Access Server.

 

Note:  Restart the World Wide Web Publishing Service is required for changes to take immediate effect

Note: Verify the NTFS Permissions match with the existing file

 

1.     On the Exchange Server where AttachView is located, download and save the updated DLL from the following link http://w3.messageware.com/download/support/KB/441_Navigation_Fix.zip

2.     Extract the contents to a temporary location

3.     Navigate to D:\Program Files\Messageware\AttachView\Service Worker

a.     Rename the AV_ServiceWorker.dll to AV_ServiceWorker.old

b.    Paste the new AV_ServiceWorker.dll to this location

c.     Confirm the NTFS permissions match those of the pre-existing file

4.     Restart the World Wide Web Publishing Service for changes to take effect.

5.     Users will now be able to view attachments with AttachView after navigating between messages using the arrow buttons.

 

 

This article applies to the following products:
     Messageware AttachView 2007