Users receive Failed to import Holiday Sections error when doing manual import of holidays

This article applies to the following products:
     Messageware Plus Pack 2007 v2.1a

 

SYMPTOM

 

When manually importing holiday files from the Options page in OWA user receives the following error:

 

Failed to import holiday sections

 

 

CAUSE

 

This issue may occur when there is a formatting error in the holiday.hol file.

 

 

RESOLUTION

 

To correct this issue, follow the steps below to properly format the holiday.hol file

 

Note:  Restart the World Wide Web Publishing Service is required for changes to take immediate effect

 

1.     Open the holiday.hol file located along the following path

\Program Files\Messageware\Plus Pack\Holiday\Import\Holiday.hol

2.     Ensure the format of the file is as follows

[Name of Calendar] #   

Holiday Name,year/month/day

The name of the calendar is contained in square brackets followed by a space and # represents the number of holidays in the calendar

Holiday Name is followed by a comma, no spaces and then the date in year/month/day format

3.     Restart the World Wide Web Publishing Service for changes to take effect

 

 

This article applies to the following products:
     Messageware Plus Pack 2007 v2.1a