In a CAS to CAS proxy environment Messageware features appear to be missing or inactive

This article applies to the following products: 
     Messageware CalendarShare 2009 (Build 755)

     Messageware Plus Pack 2009 (Build 759)

     Messageware NavGuard 2009 (Build 749)

     Messageware OWA Print 2009 (Build 758)

 

 

SYMPTOM

 

In a messaging environment where CAS to CAS proxy is configured, users may experience missing Messageware functionality in Outlook Web Access

 

CAUSE

 

This behavior may occur when the two CAS servers are located in two separate Active Directory Sites and the requests are being proxied from one CAS to another.

 

RESOLUTION

 

To correct this behavior apply the steps below on all the Client Access Servers that have Messageware products installed on them.

 

Note: Restarting the World Wide Web Publishing Service is required

Note: The following needs to be applied on all CAS servers where Messageware is installed

Note: Verify the NTFS permissions match with the existing files

 

1.     On the CAS, download and extract the following to a temporary location

http://w3.messageware.com/download/support/kb/389_CAStoCASProxy_Post_FixR759.zip

2.     Navigate to the following location \Program Files\Messageware\Common Files\

a.     Rename the existing CoreServices.dll to CoreServices.old

b.    Paste the updated CoreServices.dll

c.     Verify NTFS permissions match

3.     Navigate to the following location \Program Files\Microsoft\Exchange Server\ClientAccess\Owa\Bin

a.     Rename the existing Messageware.Common.dll to Messageware.Common.old

b.    Paste the updated Messageware.Common.dll

c.     Rename the existing Messageware.Common.Filters.dll to Messageware.Common.Filters.old

d.    Paste the updated Messageware.Common.Filters.dll

e.     Rename the existing Messageware.Exchange.Web.UI.Print.dll to Messageware.Exchange.Web.UI.Print.dll.old

f.     Paste the updated Messageware.Exchange.Web.UI.dll

g.    Verify the NTFS permissions match with the existing files

4.     Restart the World Wide Web Publishing Service for changes to take immediate effect

5.     Clear the client side browser cache and Login to OWA

 

 

This article applies to the following products: 
     Messageware CalendarShare 2009 (Build 755)

     Messageware Plus Pack 2009 (Build 759)

     Messageware NavGuard 2009 (Build 749)

     Messageware OWA Print 2009 (Build 758)