Users receive a "Processing Error" when printing Calendars using OWA Print

This article applies to the following products:
     Messageware OWA Print 2007 v1.0a

 

SYMPTOM

 

When printing a calendar using OWA Print users receive the following error:

 

Processing Error:

Object reference not set to an instance of an object

 

 

CAUSE

 

This issue occurs when the user's mailbox language and time zone is configured to German language

 

RESOLUTION

 

To correct this issue follow the steps below on obtaining an updated DLL to apply on the Client Access Server.

 

Note:  Restart the World Wide Web Publishing Service is required for changes to take immediate effect

Note: Verify the NTFS Permissions match with the existing file

 

1.     On the CAS, download and extract the following file to a temporary location http://w3.messageware.com/download/support/kb/385_OWA_Print_R758_PostFix.zip

2.     Navigate to the following location \Program Files\Microsoft\Exchange Server\ClientAccess\owa\bin

a.     Rename the existing Messageware.Exchange.Web.UI.Print.dll to Messageware.Exchange.Web.UI.Print.old

b.    Paste the updated Messageware.Exchange.Web.UI.Print.dll

c.     Verify the NTFS permissions match

d.    Restart the World Wide Web Publishing Service for changes to take immediate effect

3.     Clear the client side cache and login to OWA

4.     Users will now be able to successfully print calendars

 

 

This article applies to the following products:
     Messageware OWA Print 2007 v1.0a