When a user logs off and logs back into OWA the list of shared calendars does not populate

This article applies to the following products:
     Messageware CalendarShare 2007

 

 

SYMPTOM

 

After opening one or more shared calendar, when the user logs off and logs back into OWA, the list of shared calendars does not populate.

 

CAUSE

 

This behavior occurs because the hidden message of the delegate user does not get updated dynamically with the information from the OWA session when the shared calendars are accessed.

 

RESOLUTION

 

To correct this issue apply the hot fix below on the Exchange server where CalendarShare is installed.

 

1.     Download and Extract the following files to a temporary location on the CAS http://w3.messageware.com/download/support/kb/337_SharedCalendar_Fix.zip

2.     Double click the unregister.bat file to unregister the MwExchangeAccess2.dll

3.     On the CAS, navigate to \Program Files\Messageware\Common Files\bin

a.    Rename the existing MwExchangeAccess2.dll to MwExchangeAccess2.old

b.    Paste in the new MwExchangeAccess2.dll

c.    Note: Verify that the NTFS permissions on the new file match with those of the previous one

4.     Double click on the register.bat file to register the following DLL "MwExchangeAccess2.dll"

5.     Restart the World Wide Web Publishing Service for changes to take effect

6.     Clear the browser cache on the client machine prior to logging into OWA and confirm if the issue remains

 

 

This article applies to the following products:
     Messageware CalendarShare 2007