When adding delegates the following error occurs: One or more users could not be added to the folder access list

This article applies to the following products:
     Messageware CalendarShare 2003

 

 

SYMPTOM

 

When a user adds a delegate by selecting a recipient from the GAL the following error message:

 

“One or more users could not be added to the folder access list. Non-local users cannot be given rights on this server”

 

CAUSE

 

This issue occurs due to a missing code when trying to add a delegate located on a sub-domain

 

 

RESOLUTION

 

Apply the steps below to correct this behavior.

 

Note: Restarting the World Wide Web Publishing Service is required

Note: When copying files to a specified location, verify the NTFS permissions match with the existing files

 

1.     On the Exchange Server where CalendarShare 3.0 is located, download and extract the updated DLLs from the following link http://w3.messageware.com/download/support/kb/335_ManageDelegates_LocalUsers.zip

2.     Extract the contents to a temporary location (CalendarShare.dll, CalendarShareDelegation.dll, CalendarShareIsapi.dll, MW_CalendarRes.dll, mw_CalManPerms.js)

3.     Navigate to \Program Files\Messageware Incorporated\CalendarShare for Outlook Web Access\VDIR\bin

a.     Rename the CalendarShare.dll to CalendarShare.old

b.    Paste the new CalendarShare.dll to this location

c.     Rename the CalendarShareDelegation.dll to CalendarShareDelegation.old

d.    Paste the new CalendarShareDelegation.dll to this location

e.     Rename the CalendarShareIsapi.dll to CalendarShareIsapi.old

f.     Paste the new CalendarShareIsapi.dll to this location

4.     Navigate to \Program Files\Messageware Incorporated\CalendarShare for Outlook Web Access\Resource

a.     Rename MW_CalendarRes.dll to MW_CalendarRes.old2

b.    Paste the new MW_CalendarRes.dll to this location

5.     Navigate to \Program Files\Exchsrvr\exchweb\Controls

a.     Rename the mw_CalManPerms.js to mw_CalManPerms.old

b.    Paste the new mw_CalManPerms.js

6.     Restart the World Wide Web Publishing Service for changes to take effect.

7.     Clear the browser cache on the client computer and login to OWA

 

 

This article applies to the following products:
     Messageware CalendarShare 2003