Users receive "page has expired (59 - 0x0)" error when viewing attachments

This article applies to the following products:
     Messageware AttachView 2003

 

 

SUMMARY

 

When viewing attachments users intermittently receive the following error message:

"page has expired (59 - 0x0)"

 

This issue pertains to scenarios in which OWA connections are established in a Network Load Based (NLB) environment.

 

CAUSE

 

When a user first views an attached file, the attachment is converted into an html file that is temporarily cached on the Exchange Server.

 

For the converted file to display correctly the conversion request must be handled by the Exchange server which originally authenticated the user when the OWA session was established. If the conversion request is handled by a different Exchange server, the conversion will fail since the path to the temporarily cached html files resides on the Exchange server which originally authenticated the user to the OWA session. This will result in a "page has expired (59 - 0x0)" error.

 

RESOLUTION

 

To correct this behavior, enable the persistence option on the Network Load Balancer to ensure that OWA requests are consistently directed to the same server during an active OWA session until the user has logged off.

 

 

This article applies to the following products:
     Messageware AttachView 2003